Unable to use google search, youtube and some other sites(Not all the time but most of the time)



Hi friends,

I'm having this problem for a week. So the probelm is basicaly the title, I've tried chrome, edge, firefox and someother browsers. And this intrutpition will affact all of them, So I guess is not a browser issue. My internet is fine, I can use steam and other software that requries network conneciton, and the speedtest shows my wifi is in a goodshape.

This situions can be breakdown in to serval types:

1. Cant use google and youtube on all browsers, says "ERR_CONNECTION_TIMED_OUT" or "Not a private connection"(ERR_CERT_COMMON_NAME_INVALID)

2.Able to use google or youtube or both on one browser, but not on others, or able to open Youtube on chrome, but can't open google on chrome, the funny thing about this situation is that for most of the time, I can only youtube but not google, if this is the case, 99% of the time, if I open up a video, the video simply wont load, I can still check the comment and other videos but the it's just a inifinity loading screen, by the way, the error is still "ERR_CONNECTION_TIMED_OUT" or "Not a private connection"


1.The intruption happens randomly, sometime I can use eveything just like the oldtime, and the next minute everything stops working.

2.I had no problem this noon, however, I can no longer use those sites now. I noticed that the update reminder on my crhome despear(I hate update). Also, if I had no problem, my discord opens up smoothly. If I had problem, the discord won't open, it will simply says "Checking for new update" or "Fail to update, retry in ## secs"

3.Only google serivce I can use is gmail, others like map and search will give me errors

4.I use google for my youtube account. I noticed that if nothings goes, the youtube will use google account to login. If intrupotion happens and I can use google, it shows me that I'm not logged in.

5.I have tried to clear cache, reset modern and router, calling internet provider tech support, nothings works

6.All other devices works fine.

7.I had this problem 3 months ago, I thought the probelm is newest window update So I rolled back to the previous version. It did fixed the intruption.I did it again this time, trying to fix it, I updated the window then rolled back, but it didn't work this time.

Continue reading...
Top Bottom